FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Fri Jun 18, 2021 20:05



Post new topic Reply to topic  [ 13 posts ] 
configure: error: FUSE >= 2.6.0 was not found. 
Author Message

Joined: Thu Oct 11, 2007 19:40
Posts: 5
Post configure: error: FUSE >= 2.6.0 was not found.
I get this error from ./configure script when building the actual version ntfs-3g-1.1104.
Question is : I have installed on ubuntu FF fuse-utils and libfuse2 both 2.6.3-1ubuntu2 version, which doesn't seem enough, despite the version is higher then 2.6.0.
Should I go the way to install the newest fuse-2.7.1 from source as an addition to it or uninstall completely fuse-utils with libfuse2 2.6.3 and then install fuse-2.7.1 from source ?


Tue Nov 13, 2007 11:56
Profile
Tuxera CTO

Joined: Tue Nov 21, 2006 23:15
Posts: 1648
Post 
The full error message says: "Either FUSE is not fully installed (e.g. fuse, fuse-utils, libfuse, libfuse2, libfuse-dev, etc packages) or files from an old version are still present."


Tue Nov 13, 2007 13:06
Profile

Joined: Thu Oct 11, 2007 19:40
Posts: 5
Post 
yes, it says, true is :
1)using method one - removing all old stuff and installing new fuse 2.7.1 and latest ntfs-3g creates a new boot message : 'fuse filesystem already available' (coming from /etc/rc0.d/S41fuse -> ../init.d/fuse script probably) and I cannot get ntfs-config working (also installed from source) - it fails with error messages.

2)using method two - just installing newest fuse as an addition to already installed older things also invokes the boot message, but otherwise everything seems to be working so far,ntfs-config stays working from previous installation, though keeping dependencies to older, unused stuff

I


Tue Nov 13, 2007 14:11
Profile

Joined: Thu Oct 11, 2007 19:40
Posts: 5
Post 
installing latest fuse also with the lastes ntfs-3g as for the method two, of course


Tue Nov 13, 2007 14:13
Profile

Joined: Fri Nov 23, 2007 04:22
Posts: 3
Post 
I get the same problem, compiling fuse 2.7.1 from source and then attempting to configure the latest ntfs-3g.. which boggles me because I did the same on another system and it works fine

is there a source package for fuse-utils or libfuse or is that part of compiling fuse 2.7.1 (i thought it was)


Fri Nov 23, 2007 04:24
Profile

Joined: Fri Nov 23, 2007 04:22
Posts: 3
Post 
I think I figured it out... when checking for the current FUSE version, ntfs-3g uses the package pkg-config. Installing this package fixed this error for me.


Fri Nov 23, 2007 04:44
Profile
Tuxera CTO

Joined: Tue Nov 21, 2006 23:15
Posts: 1648
Post 
Thanks a lot penpen! I've added detection for pkg-config. If it's not installed then the compilation will fail with this error message starting from the next NTFS-3G release:

Code:
checking for pkg-config... no
configure: error: pkg-config wasn't found! Please install from your vendor, or see http://pkg-config.freedesktop.org/wiki/


Regards, Szaka


Sat Nov 24, 2007 22:00
Profile

Joined: Thu Nov 29, 2007 06:32
Posts: 28
Location: North Carolina
Post 
I just registered to report this very problem on Debian Etch AMD64. It came with fuse 2.5.3, so I stopped the service using "/etc/init.d/fuse stop", built and installed fuse 2.7.1, and got this message. However, if I install the package using aptitude, I am screwed again because that is version 2.5.3! So how can I make this thing realize that I do indeed have 2.7.1 installed??


Thu Nov 29, 2007 06:38
Profile
Tuxera CTO

Joined: Tue Nov 21, 2006 23:15
Posts: 1648
Post 
Install the pkg-config package.


Thu Nov 29, 2007 14:13
Profile

Joined: Thu Nov 29, 2007 06:32
Posts: 28
Location: North Carolina
Post 
Oh that's the problem? I mis-read the information in this post, or took it the wrong way. I was under the impression that if I hadn't installed the package using apt-get, aptitude, or whatever, that even though the correct version was built, it wouldn't show up in the packages list and thus fail. I will attempt this in an hour or two when I get out of class and can use the laptop freely.


Thu Nov 29, 2007 16:06
Profile

Joined: Wed Jun 08, 2011 03:55
Posts: 1
Post Re: configure: error: FUSE >= 2.6.0 was not found.
I had installed pkg-config, but still has a same error.
I had install fuse2.8

checking for pkg-config... /usr/bin/pkg-config
checking for fuse >= 2.6.0... configure: error: ntfs-3g requires FUSE >= 2.6.0. Please see http://fuse.sf.net/ or install __all__ FUSE packages (e.g. fuse, fuse-utils, libfuse, libfuse2, libfuse-dev) or remove already installed __older__ FUSE.


Wed Jun 08, 2011 04:03
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: configure: error: FUSE >= 2.6.0 was not found.
Hi,

Quote:
I had installed pkg-config, but still has a same error.
I had install fuse2.8

Please post what is returned by :
Code:
pkg-config --modversion fuse

Quote:
checking for fuse >= 2.6.0... configure: error: ntfs-3g requires FUSE >= 2.6.0

Did you install the fuse development package (e.g. libfuse-dev, may have a different name) ?
Also what kernel are you using ? Please post what is returned by :
Code:
uname -a


Regards

Jean-Pierre


Wed Jun 08, 2011 12:32
Profile

Joined: Thu Jul 21, 2011 09:44
Posts: 1
Post Re: configure: error: FUSE >= 2.6.0 was not found.
Install the pkg-config package.


Thu Jul 21, 2011 09:47
Profile WWW
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.