FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Tue Aug 03, 2021 20:53

Post new topic Reply to topic  [ 4 posts ] 
remove_hiberfile not working 
Author Message

Joined: Sat Apr 12, 2008 23:00
Posts: 3
Post remove_hiberfile not working
I am running PC-BSD 1.5(FreeBSD 6.3 based) and am trying to unable NTFS read/write support.

I have installed the file system driver with this command
cd /usr/ports/sysutils/fusefs-ntfs/ && make install clean
(Yes, i updates ports before)

kldload /usr/local/modules/fuse.ko
with no errors

after inserting an NTFS formatted usb thumb drive, I use this to mount
ntfs-3g /dev/da0s1 /mnt/stick
It returns with an error about he partition being hibernated and asks for the -o remove_hiberfile flag.

I tried
ntfs-3g /dev/da0s1 /mnt/stick -o remove_hiberfile
and get the same error.
All commands were issued as root. the error has been copied from konsole below.

pcbsd# mount -t ntfs-3g -o remove_hiberfile /dev/da0s1 /mnt/stick
Error opening '/dev/da0s1': Operation not permitted
Failed to mount '/dev/da0s1': Operation not permitted
The NTFS partition is hibernated. Please resume and shutdown Windows
properly, or mount the volume read-only with the 'ro' mount option, or
mount the volume read-write with the 'remove_hiberfile' mount option.
For example type on the command line:

mount -t ntfs-3g /dev/da0s1 /mnt/stick -o remove_hiberfile
(NOTE: this command also returns the same error)

Has anyone seen this before? Any help would be appreciated.

Sat Apr 12, 2008 23:13
Tuxera CTO

Joined: Tue Nov 21, 2006 23:15
Posts: 1648
Your problem is not with hibernation but the partition device (/dev/da0s1) can't be opened because of "Operation not permitted".

Linux doesn't have this message for open(2) and the FreeBSD behavior tricked the hint part of ntfs-3g.

I hope this helps to narrow down the problem and find the real reason.

Sun Apr 13, 2008 04:24

Joined: Sat Apr 12, 2008 23:00
Posts: 3
I figured that hibernation wasn't the problem. After I formatted the usb drive in windows, I safely ejected it.

Are you suggesting that the problem is that the ntfs-3g driver doesn't understand the BSD device/partition naming scheme?

the same usb dive auto-mounts and manually mounts in read-only just fine. But I guess that has nothing to do with the ntfs-3g.

I also tried mounting with da0 instead of da0s1, as follows
ntfs-3g /dev/da0 /mnt/stick
still get the same error.

Still checking this out.
Thanks for the reply though.

Sun Apr 13, 2008 23:06

Joined: Sat Apr 12, 2008 23:00
Posts: 3
I got it. it was a problem with my unmounting the drive first.

Now to figure out auto-mounting with read/write

Mon Apr 14, 2008 06:40
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.