FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Sun Nov 29, 2020 00:29



Post new topic Reply to topic  [ 1 post ] 
NTFS mounts automatically, but not when using ntfs-3g... 
Author Message

Joined: Mon Dec 13, 2010 09:42
Posts: 1
Post NTFS mounts automatically, but not when using ntfs-3g...
I've posted this on the FreeBSD forums as well, and based on another thread there and one here, I'm curious if I'm experiencing what the other user is experiencing. I don't know if my problem is with NTFS-3G or with Gnome. I'm using FreeBSD 8.1 and running Gnome 2.32.

I managed to get all my NTFS drives mounting automatically when logging into Gnome, however it is only read-only, so I installed the sysutils/fusefs-ntfs port.

I followed the instructions in /usr/local/share/doc/hal-0.5.14/README.fuse

Quote:
Mounting Fuse File Systems with HAL
-----------------------------------

$FreeBSD: ports/sysutils/hal/files/README.fuse,v 1.3 2010/05/10 21:18:39 kwm Exp $

Hal supports mounting Fuse device-backed file systems (e.g. NTFS). To enable
this feature, copy the included /usr/local/share/hal/mount-fuse script
to /sbin. Make sure this script is executable. Edit the script, and change
the FUSE_HELPER environment variable to the name of the executable which
will actually mount the Fuse volume (e.g. for NTFS, this is ``ntfs-3g'').

Finally, the script must be renamed to ``mount_FSNAME''. FSNAME is the name
of the file system type (e.g. for NTFS, this is ``ntfs''). If there is
already an executable in /sbin or /usr/sbin with this name, the
existing executable must be renamed or deleted.

As is stated in the examples above, overriding FreeBSD's existing NTFS
support with Fuse's ntfs-3g is the most common use case for this. The
ntfs-3g Fuse driver uses different mount options than FreeBSD's included
mount_ntfs. GNOME transparently supports switching between ntfs and
ntfs-3g. Simply edit the following GConf key in the GNOME
Configuration Editor (i.e. gconf-editor):

/system/storage/default_options/ntfs/fstype_override

Set the value to ``ntfs-3g'', then add your desired ntfs-3g options to the
following GConf key:

/system/storage/default_options/ntfs-3g/mount_options

Other desktop systems may have similar options.


Since the document says "GNOME transparently supports switching between ntfs and ntfs-3g", I left the option in "/system/storage/default_options/ntfs-3g/mount_options" as just "locale=" (which is what is there by default), however, after following the instructions, the drives no longer load on startup, and they can't be mounted manually either.

Is this likely just a case of me not doing something properly, or is it something to do with ntfs-3g/gnome?


Mon Dec 13, 2010 10:08
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.