FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Sun Jan 23, 2022 01:32

Post new topic Reply to topic  [ 3 posts ] 
FreeBSD 7.0 (Invalid argument) 
Author Message

Joined: Tue Oct 21, 2008 16:56
Posts: 1
Post FreeBSD 7.0 (Invalid argument)

I've got FreeBSD 7.0-RELEASE + USB HDD TEAK drive, and have some troubles using NTFS-3G there. Driver is installed (I tried to reinstall it, but no changes):
%pkg_info | grep fuse
fusefs-kmod-0.3.9.p1_2 Kernel module for fuse
fusefs-libs-2.7.3   FUSE allows filesystem implementation in userspace
fusefs-ntfs-1.2531  Mount NTFS partitions (read/write) and disk images

Module fuse.ko is also enabled:
# kldstat | grep fuse
6    1 0xcad34000 e000     fuse.ko

When i connect my drive dmesg says:
%dmesg | tail
umass0: <Super Top USB 2.0  IDE DEVICE, class 0/0, rev 2.00/2.01, addr 2> on uhub6
da0 at umass-sim0 bus 0 target 0 lun 0
da0: <FUJITSU MHV2120AH \\0000\\0000> Fixed Direct Access SCSI-0 device
da0: 40.000MB/s transfers
da0: 114473MB (234441648 512 byte sectors: 255H 63S/T 14593C)
GEOM_LABEL: Label for provider da0s1 is ntfs/Lexs_mbl.

Then I'm trying to mount it different ways:
ntfs-3g /dev/da0s1 /mnt/hdd
mount_ntfs-3g /dev/da0s1 /mnt/hdd

But every time i've got the same error:
Failed to read bootsector (size=0)
Failed to mount '/dev/da0s1': Invalid argument
The device '/dev/da0s1' doesn't have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?

This HDD mounts without any problems on linux (Mandriva/Ubintu/etc.), and even with standart ntfs module on FreeBSD:
# mount_ntfs /dev/da0s1 /mnt/hdd
# mount | grep /dev/da0s1
/dev/da0s1 on /mnt/hdd (ntfs, local)

What can I do? Help, plz!

Tue Oct 21, 2008 17:07

Joined: Thu Dec 18, 2008 16:36
Posts: 1
Post Same Problem
I'm running PCBSD in the VMWare virtual machine. An external 160GB Western Digital with a newly formatted NTFS file system is found, however any attempt to mount fails.

I initialized the partition as NTFS under VMW-PC-BSD, then formatted under WinXP.

Moved the drive to my Vista machine which is running VMWare Player, booted PC-BSD with the USB drive connected. Device da0 was detected on startup, and correctly reported the volume label.

GEOM_LABEL: Label for provider da0s1 is ntfs/NTFSWD160

Subsequent attempts to mount using variations of

mount -t ntfs-36 /dev/da0s1 /mnt/usb
Could not open /dev/da0s1: Invalid argument.

all failed.

However, the USB autoloader continued to report and correctly identify the NTFS label of the device. I know I can read/write the /dev/da0 because I did it with dd.

It also created a device: /dev/ntfs/NTFSWD160

Which is the label on the drive. Tried mounting that device, got:

Operation not supported by device

Any suggestions appreciated.

Thu Dec 18, 2008 16:46
Tuxera CTO

Joined: Tue Nov 21, 2006 23:15
Posts: 1648

Please see the 'Operation not supported' here: http://forum.ntfs-3g.org/viewtopic.php?p=4422#4422

The 'Invalid argument' (device size=0) usually suggests that the device driver is not loaded, initialized, setup properly in the kernel.

Sat Jan 03, 2009 21:37
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.