FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Sat Jan 16, 2021 05:11



Post new topic Reply to topic  [ 14 posts ] 
Updated RPMS for FC6 & RHEL 4 
Author Message

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post Updated RPMS for FC6 & RHEL 4
From my point of view both fuse and ntfs-3g RPMS avaliable through FC 6 extras repo are too old. Even more, I didn't find any RPMS for RHEL 4. Thus I did them by myself.

fuse 2.6.1 for FC 6 and for RHEL 4. Please mention that this RPMS were build for exact versions of kernel (2.6.18-1.2868.fc6 and 2.6.9-42.0.3.EL) and would put new fuse module in a corresponding directory. Do not forget to put module in correct directory, do depmod and reload fuse module. Command
Code:
grep 'fuse' /var/log/messages
should provide you result simular to this:
Code:
fuse init (API version 7.8)
take care about API version!

ntfs-3g-20061218 for FC 6 and for RHEL 4.

P.S. Site is mixed with Russian and English language, sorry for this.

_________________
Red Hat Certified Examiner


Tue Dec 26, 2006 01:02
Profile

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post 
Updated RPMS ntfs-3g-20070102 for FC 6 and for RHEL 4.


szaka, please change fuse version required for ntfs-3g to work on main page. As well as I understand now it 2.6.1

Take care that original fedora fuse package doesn't update fuse module which comes with fedora kernels and out of date.

_________________
Red Hat Certified Examiner


Tue Jan 02, 2007 20:01
Profile
Tuxera CTO

Joined: Tue Nov 21, 2006 23:15
Posts: 1648
Post Updated RPMS for FC6 & RHEL 4
Hi Alexey,

On Tue, 26 Dec 2006, Alexey wrote:

Quote:
From my point of view both fuse and ntfs-3g RPMS avaliable through FC 6
extras repo are too old. Even more, I didn't find any RPMS for RHEL 4.
Thus I did them by myself.

Thanks! I hoped Red Hat would provide all the rpms but it doesn't seem so
for the updated FUSE unfortunately.

Quote:
fuse 2.6.1 for FC 6 (http://marush.com/2006/12/26/fuse-261-for-fc6/) and
for RHEL 4 (http://marush.com/2006/12/26/fuse-261-for-rhel-4-srpm/).
Please mention that this RPMS were build for exact versions of kernel
(2.6.18-1.2868.fc6 and 2.6.9-42.0.3.EL) and would put new fuse module in
a corresponding directory. Do not forget to put module in correct
directory, do depmod and reload fuse module.

Do you mean all these are done by the rpm's? That would be wonderful! Quite
many people want to upgrade but not everybody can because it's too complex.

Could you make the shortest, clearest, step by step instructions how even
the youngest and less experienced Linux user could make the upgrade easily?

Quote:
please change fuse version required for ntfs-3g to work on main page. As
well as I understand now it 2.6.1

2.6.0 is also ok but of course 2.6.1 is preferred.

Szaka


Sun Jan 07, 2007 14:00
Profile

Joined: Sat Jan 20, 2007 00:15
Posts: 3
Post 
Alexey wrote:
Take care that original fedora fuse package doesn't update fuse module which comes with fedora kernels and out of date.

Hi, can you explain or give me some link to how to update the fuse module?
when I type grep 'fuse' /var/log/messages still show the API version 7.7.
there is no fuse directory in my file system

thanks in advance


Sat Jan 20, 2007 00:30
Profile

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post 
Sorry for long wait, I'll write big post with some explanations tomorrow.

I've assembled updated SRPM & RPMS fo RHEL 4. I'll not provide update FC 6 anymore, but anyone can build it using updated SRPM.

_________________
Red Hat Certified Examiner


Wed Jan 31, 2007 01:45
Profile

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post 
RC1 rpms avaliable for use.

_________________
Red Hat Certified Examiner


Wed Feb 07, 2007 21:45
Profile

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post 
Fuse 2.6.3 RPMS & SRPM for RHEL4.

_________________
Red Hat Certified Examiner


Sun Feb 11, 2007 04:24
Profile

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post 
ntfs3g version 1.0

_________________
Red Hat Certified Examiner


Wed Feb 21, 2007 23:41
Profile

Joined: Wed Mar 14, 2007 16:31
Posts: 1
Post What am I missing? fuse disagrees struct_module?
RH4 Upd 4, 2.6.9-42.ELsmp

I got the rpms from your site at http://marush.com/2007/03/08/fuse-263-3 ... el-4-srpm/

and when I attempt to install them, all go in except fuse-kernel-module which shows

Preparing... ########################################### [100%]
1:fuse-kernel-module warning: user avm does not exist - using root
warning: group avm does not exist - using root
########################################### [100%]
FATAL: Could not open '/boot/System.map-2.6.9-42.0.3.EL': No such file or directory
error: %post(fuse-kernel-module-2.6.3-3.EL4.i686) scriptlet failed, exit status 1

under /boot I have System.map-2.6.9-42.EL and System.map-2.6.9-42.ELsmp

If I try to just hack it in there and make System.map-2.6.9-42.0.3.EL a softlink to System.map-2.6.9-42.ELsmp, the rpm will install, but a modprobe -v fuse shows

FATAL: Could not open '/lib/modules/2.6.9-42.ELsmp/kernel/fs/fuse/fuse.ko': No such file or directory

If I try to hack that together and copy the ...kernel/fs/fuse subdir from /lib/modules/2.6.9-42.0.3.EL to /lib/modules/2.6.9-42.ELsmp/kernel/fs and then do modprobe -v fuse, I get
insmod /lib/modules/2.6.9-42.ELsmp/kernel/fs/fuse/fuse.ko
FATAL: Error inserting fuse (/lib/modules/2.6.9-42.ELsmp/kernel/fs/fuse/fuse.ko): Invalid module format

and in dmesg I see fuse: disagrees about version of symbol struct_module

help?


Wed Mar 14, 2007 16:53
Profile ICQ YIM

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post 
See comments at my site.

_________________
Red Hat Certified Examiner


Thu Mar 15, 2007 23:01
Profile

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post 
I've assembled 1.2129 version. 'Cause of src changes have to create to patches and change spec.
Could some one check if new rpm install smooth. I can't do quality check in the nearest future.

_________________
Red Hat Certified Examiner


Wed Jan 30, 2008 15:50
Profile

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post 
Alexey wrote:
I've assembled 1.2129 version. 'Cause of src changes have to create two patches and change spec.
Could some one check if new rpm install smooth. I can't do quality check in the nearest future.

_________________
Red Hat Certified Examiner


Wed Jan 30, 2008 23:48
Profile

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post Re: Updated RPMS for FC6 & RHEL 4
As I found at site statistic some people steel need RPMS for RHEL4.

I've updated them for the newest source 2009.2.1, haven't tested them by myself.

http://marush.com/2009/03/13/ntfs-3g-200921-el4/

Built RPMS for RHEL5 also, not sure if anyone need them.

http://marush.com/2009/03/13/ntfs-3g-200921-el5/

_________________
Red Hat Certified Examiner


Fri Mar 13, 2009 01:05
Profile

Joined: Sun Dec 24, 2006 02:28
Posts: 25
Post Re: Updated RPMS for FC6 & RHEL 4
Updated for 2009.4.4 version http://marush.com/2009/04/09/ntfs-3g-200944-el5/

_________________
Red Hat Certified Examiner


Wed Apr 08, 2009 23:08
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.