FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Wed Nov 25, 2020 10:03



Post new topic Reply to topic  [ 6 posts ] 
mount.ntfs-3g errors when passed -s 
Author Message

Joined: Fri Aug 08, 2014 13:31
Posts: 1
Post mount.ntfs-3g errors when passed -s
mount commands in linux support -s (for sloppy mount) ntfs-3g errors when passed in -s, rather than ignoring it (bearable) or implementing it properly (preferred)


Fri Aug 08, 2014 13:34
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: mount.ntfs-3g errors when passed -s
Hi,

Quote:
ntfs-3g errors when passed in -s, rather than ignoring it (bearable) or implementing it properly (preferred)

Please give examples (not sure whether improvement is possible).

Regards

Jean-Pierre


Fri Aug 08, 2014 17:26
Profile

Joined: Mon Dec 15, 2014 00:44
Posts: 1
Post Re: mount.ntfs-3g errors when passed -s
This incompatability is getting me too.

I'm not sure what example is required beyond
# mount -s /dev/sda1 /mnt/public
> ntfs-3g: Unknown option '-s'.

This got me because a recent update (automount 5.0.8 in raspbian) has caused automount to use -s when mounting a device, and my external drive has spontaneously stopped mounting.

Ignoring -s would solve this problem for me.


Mon Dec 15, 2014 00:59
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: mount.ntfs-3g errors when passed -s
Hi,

Quote:
This got me because a recent update (automount 5.0.8 in raspbian) has caused automount to use -s when mounting a device, and my external drive has spontaneously stopped mounting.

How did you diagnose the option -s was used ? Under what circumstances do you get this option ? hot plugged-in device ? what is in your /etc/fstab ?

Please try the attached patch (untested, as I have not been able to produce the error).

Regards

Jean-Pierre


Attachments:
sloppy-mount.patch.gz [377 Bytes]
Downloaded 924 times
Mon Dec 15, 2014 10:04
Profile

Joined: Wed Apr 15, 2015 22:05
Posts: 2
Post Re: mount.ntfs-3g errors when passed -s
jpa wrote:
Hi,

Quote:
This got me because a recent update (automount 5.0.8 in raspbian) has caused automount to use -s when mounting a device, and my external drive has spontaneously stopped mounting.

How did you diagnose the option -s was used ? Under what circumstances do you get this option ? hot plugged-in device ? what is in your /etc/fstab ?


I would confirm the changed feature. In the last LMDE 32 bit version -s is ignored by ntfs-3g.

/usr/sbin/automount -V
Linux automount version 5.0.7

ntfs-3g -V
ntfs-3g 2013.1.13AR.1 external FUSE 29

Code:
/usr/sbin/automount  -vdf

Code:
lookup_mount: lookup(file): dosc -> -fstype=ntfs,umask=000,uid=1002,gid=1000 :LABEL=sata1-sda1-c
parse_mount: parse(sun): expanded entry: -fstype=ntfs,umask=000,uid=1002,gid=1000 :LABEL=sata1-sda1-c
parse_mount: parse(sun): gathered options: fstype=ntfs,umask=000,uid=1002,gid=1000
parse_mount: parse(sun): dequote(":LABEL=sata1-sda1-c") -> :LABEL=sata1-sda1-c
parse_mount: parse(sun): core of entry: options=fstype=ntfs,umask=000,uid=1002,gid=1000, loc=:LABEL=sata1-sda1-c
sun_mount: parse(sun): mounting root /mnt/misc, mountpoint dosc, what LABEL=sata1-sda1-c, fstype ntfs, options umask=000,uid=1002,gid=1000
do_mount: LABEL=sata1-sda1-c /mnt/misc/dosc type ntfs options umask=000,uid=1002,gid=1000 using module generic
mount_mount: mount(generic): calling mkdir_path /mnt/misc/dosc           
                                      vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
mount_mount: mount(generic): calling mount -t ntfs -s -o umask=000,uid=1002,gid=1000 LABEL=sata1-sda1-c /mnt/misc/dosc
                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
spawn_mount: mtab link detected, passing -n to mount
mount_mount: mount(generic): mounted LABEL=sata1-sda1-c type ntfs on /mnt/misc/dosc


LMDE Betsy 64Bit

/usr/sbin/automount -V
Linux automount version 5.0.8

ntfs-3g -V
ntfs-3g 2014.2.15AR.2 integrated FUSE 28

Code:
lookup_mount: lookup(file): dosc -> -fstype=ntfs,gid=1000,dmask=002,fmask=113 :LABEL=sda1-dosc
parse_mount: parse(sun): expanded entry: -fstype=ntfs,gid=1000,dmask=002,fmask=113 :LABEL=sda1-dosc
parse_mount: parse(sun): gathered options: fstype=ntfs,gid=1000,dmask=002,fmask=113
parse_mount: parse(sun): dequote(":LABEL=sda1-dosc") -> :LABEL=sda1-dosc
parse_mount: parse(sun): core of entry: options=fstype=ntfs,gid=1000,dmask=002,fmask=113, loc=:LABEL=sda1-dosc
sun_mount: parse(sun): mounting root /mnt/misc, mountpoint dosc, what LABEL=sda1-dosc, fstype ntfs, options gid=1000,dmask=002,fmask=113
do_mount: LABEL=sda1-dosc /mnt/misc/dosc type ntfs options gid=1000,dmask=002,fmask=113 using module generic
mount_mount: mount(generic): calling mkdir_path /mnt/misc/dosc
                                     vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
mount_mount: mount(generic): calling mount -t ntfs [color=#FF0000]-s[/color] -o gid=1000,dmask=002,fmask=113 LABEL=sda1-dosc /mnt/misc/dosc
                                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
spawn_mount: mtab link detected, passing -n to mount
>> ntfs-3g: Unknown option '-s'.     <---------------------------------------------------------------------------------------------------
>> ntfs-3g 2014.2.15AR.2 integrated FUSE 28 - Third Generation NTFS Driver
>>              Configuration type 7, XATTRS are on, POSIX ACLS are on


If I get some time I try to compile the last tarball with the patch. But it would be nice to get the behavour direct from the distribution. (Ok we could also hit the autofs autor.)

Jürgen


Wed Apr 15, 2015 22:41
Profile

Joined: Wed Apr 15, 2015 22:05
Posts: 2
Post Re: mount.ntfs-3g errors when passed -s
Quote:
If I get some time I try to compile the last tarball with the patch. But it would be nice to get the behavour direct from the distribution.
Jürgen


The last version xxx-2015-yyyy seams to have the patcb already applied. Works like before.
Thanks. Now the distro should upgrade to this version.

I am happy.

JS


Thu Apr 16, 2015 11:46
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.