FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Wed Nov 25, 2020 09:52



Post new topic Reply to topic  [ 2 posts ] 
Can't mount partition but ntfscat is working 
Author Message

Joined: Mon May 26, 2014 18:18
Posts: 1
Post Can't mount partition but ntfscat is working
Hello,

I have a broken NTFS partition (if i plug the HD on a windows it just goes up and down).

On linux the disk/aprtitions are seen, ntfsfix did its job but i still can't mount it

Code:
ntfsfix /dev/sdb3
Mounting volume... The disk contains an unclean file system (0, 0).
FAILED
Attempting to correct errors...
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdb3 was processed successfully.


But ntfs-3g can't mount it...

Code:
ntfs-3g /dev/sdb3 /mnt/windows
ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.


However ntfsls and ntfscat are working !

If i do a
Code:
ntfscat /dev/sdb3 /Users/toto/Desktop/mypdf.pdf  -f | dd  of=/tmp/test.pdf


The PDF is saved and readable in /tmp/test.pdf !

Do you know how can I copy files or directories from the ntfs partition to my ext4 partition without using ntfscat (it is not really convinient).

Thanks in advance !
Greg


Mon May 26, 2014 18:26
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: Can't mount partition but ntfscat is working
Hi,

Code:
ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error

There appears to be a major error in the cluster allocation table. Could be a hardware error or a software one. Usually this can be fixed by chkdsk (on Windows).
Quote:
However ntfsls and ntfscat are working !

Because these tools do not allocate clusters, so they need not access the allocation table.
Quote:
Do you know how can I copy files or directories from the ntfs partition to my ext4 partition without using ntfscat (it is not really convinient).

Probably ntfs-3g can be patched to ignore bitmap errors when a device is mounted read-only.... but there could be more errors.

To analyze your case further, please try the following commands (as root) :
Code:
ntfsinfo -fm /dev/sdb3
ntfsinfo -fvi 6 /dev/sdb3
ntfsresize -ni /dev/sdb3

Compress the outputs and post as an attachment.

Regards

Jean-Pierre


Tue May 27, 2014 08:40
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.