FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Wed Nov 25, 2020 10:40



Post new topic Reply to topic  [ 5 posts ] 
Cannot mount NTFS with the Sticky bit 
Author Message

Joined: Sun Apr 06, 2014 22:04
Posts: 3
Post Cannot mount NTFS with the Sticky bit
Hi,

Unfortunately I can not get the sticky bit to be set when mount:
Code:
ntfs-3g -o uid=0,gid=100,fmask=1011,dmask=1000 /dev/sdb1 /DATA

ls -al /DATA
total 200
drwxrwxrwx  1 root users  4096 Apr  6 22:21 .
...


I am using SUSE 13.1 with:
Code:
ntfs-3g 2013.1.13 external FUSE 29 - Third Generation NTFS Driver
                Configuration type 1, XATTRS are on, POSIX ACLS are off


Am I doing something wrong?

Thank you in advance!

Teddy


Sun Apr 06, 2014 22:53
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: Cannot mount NTFS with the Sticky bit
Hi,

Quote:
Unfortunately I can not get the sticky bit to be set when mount:

The sticky bit is a special permission bit mostly used for directories reserved for user uploads. Being a permission feature, it cannot only be used with Linux permissions enabled (user mapping defined).

There is no Windows equivalent for the sticky bit.

Regards

Jean-Pierre


Mon Apr 07, 2014 08:30
Profile

Joined: Sun Apr 06, 2014 22:04
Posts: 3
Post Re: Cannot mount NTFS with the Sticky bit
Thank you, Jean-Pierre, for a quick response!

But I am afraid that I do not understand your second sentence. Would you pls give me some hints on how to enable the sticky bit on mounted partition?


Mon Apr 07, 2014 17:47
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: Cannot mount NTFS with the Sticky bit
Hi,

Quote:
Would you pls give me some hints on how to enable the sticky bit on mounted partition?

You have to mount with the permissions option or define a user mapping file (see http://www.tuxera.com/community/ntfs-3g ... nd-permis$

For example, you can mount with :
Code:
ntfs-3g -o permissions /dev/sdb1 /DATA

With this option set, do not pollute your real files unless you understand the consequences, only create temporary files or directories. In particular, you can create a subdirectory and make it sticky :
Code:
[root@dimension linux]# mkdir sticky
[root@dimension linux]# ls -ld sticky
drwxr-xr-x 1 root root 0 Apr  7 18:17 sticky
[root@dimension linux]# chmod 1755 sticky
[root@dimension linux]# ls -ld sticky
drwxr-xr-t 1 root root 0 Apr  7 18:17 sticky

Notice the final 't' in "drwxr-xr-t" meaning the directory was made sticky.

Regards

Jean-Pierre


Mon Apr 07, 2014 21:24
Profile

Joined: Sun Apr 06, 2014 22:04
Posts: 3
Post Re: Cannot mount NTFS with the Sticky bit
This works!

Thanks a lot!


Mon Apr 07, 2014 21:58
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: Google [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.