FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Sat May 15, 2021 05:15



Post new topic Reply to topic  [ 3 posts ] 
Getting ERROR = > FATAL: Module fuse not found. 
Author Message

Joined: Wed May 09, 2012 10:42
Posts: 2
Post Getting ERROR = > FATAL: Module fuse not found.
Hello Sir,

This is my first post in TUXERA, i am facing this problem since long time i try to search solution for this problem on the internet but no help. so i finally decided to post this on your forum and let you guys to help me , i downloaded ntfs-3g_ntfsprogs-2012.1.15.gz and compile on my system with --enable-fuse-module option but no luck still fuse is not install in my system. i also tried to install ntfs-3g-2011.1.15.tgz with the similar option like above again no luck. I am using RHEL 5.3

#uname -a
Linux localhost.localdomain 2.6.18-128.el5xen #1 SMP Wed Dec 17 12:22:24 EST 2008 i686 i686 i386 GNU/Linux

[root@localhost ~]# modprobe fuse
FATAL: Module fuse not found.

# lsmod | grep fuse
NO luck


Please tell what i need to do to get fuse install in my system, so i can access my NTFS partions in my linux box also.

Thanks
Ashish Sood


Wed May 09, 2012 11:03
Profile

Joined: Wed May 09, 2012 10:42
Posts: 2
Post Fatal Fuse module
Hi Sir,

I would like to access my windows ntfs partions from my linux system, currently i am using RHEL 5.4 with the kernel version 2.6.18, for that i download the latest version of ntfs-3g and ntfs-progs and then i compile both of this packages using --enable-fuse-module, but no luck, when ever i trid to mound my ntfs partion i got a fatal error fuse module not installed, please suggest what should i need to do to get fuse module install in my system.

Thanks
Ashish Sood


Thu May 10, 2012 13:52
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: Getting ERROR = > FATAL: Module fuse not found.
Hi,

Quote:
This is my first post in TUXERA, i am facing this problem since long time i try to search solution for this problem on the internet but no help. so i finally decided to post this on your forum and let you guys to help me , i downloaded ntfs-3g_ntfsprogs-2012.1.15.gz and compile on my system with --enable-fuse-module option but no luck still fuse is not install in my system. i also tried to install ntfs-3g-2011.1.15.tgz with the similar option like above again no luck. I am using RHEL 5.3

The fuse kernel module is part of the kernel, and as such it is included with neither ntfs-3g nor the fuse library.
First check whether your kernel was compiled with a provision for a fuse kernel module. Do
Code:
grep FUSE /lib/modules/`uname -r`/build/.config

You should get
Code:
CONFIG_FUSE_FS=m

If so, you have to install the fuse kernel module matching your exact kernel version. This is probably available from where you got your kernel from, and with some luck this is the one you need :
ftp://ftp.pbone.net/mirror/ftp.pramberg ... p.i686.rpm
If this is not ok, you have to recompile it, for example from
fuse-kmod-2.7.4-1.2.6.18_128.1.6.el5.pp.src.rpm
You will have to install the kernel headers for your exact kernel version, and use a compiler compatible with the one used to compile the kernel.

Regards

Jean-Pierre


Wed May 16, 2012 21:46
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.