FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Sun Jun 13, 2021 23:11



Post new topic Reply to topic  [ 7 posts ] 
ntfs-3g-mount: mount failed: Invalid argument 
Author Message

Joined: Wed Nov 09, 2011 08:42
Posts: 4
Post ntfs-3g-mount: mount failed: Invalid argument
Hi!

I need to solve the problem:

Code:
~ # mount -t ntfs-3g /dev/sda1 /mnt/usb1_1/
ntfs-3g-mount: mount failed: Invalid argument
mount: mounting /dev/sda1 on /mnt/usb1_1/ failed: No such device


or

Code:
~ # ntfs-3g /dev/sda1 /mnt/usb1_1/
ntfs-3g-mount: mount failed: Invalid argument


I have the following versions:

ntfs-3g 1.2412 integrated FUSE 27
fuse init (API version 7.8)

Code:
~ # lsmod | grep fuse
fuse                   49360  0


Code:
~ # fdisk -l

Disk /dev/sda: 4042 MB, 4042259968 bytes
125 heads, 62 sectors/track, 1018 cylinders
Units = cylinders of 7750 * 512 = 3968000 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sda1               1        1018     3944719   7 HPFS/NTFS


P.S. FUSE upgrade is not possible to use the current version


Wed Nov 09, 2011 08:53
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: ntfs-3g-mount: mount failed: Invalid argument
Hi,

Code:
~ # ntfs-3g /dev/sda1 /mnt/usb1_1/
ntfs-3g-mount: mount failed: Invalid argument

Is there some information in the system log ?
Quote:
I have the following versions:
ntfs-3g 1.2412 integrated FUSE 27
[...]
P.S. FUSE upgrade is not possible to use the current version

A lot of bugs have been fixed since this prehistoric version (not supported any more).

If you cannot upgrade, you can download from http://www.tuxera.com/community/ntfs-3g-advanced/ a prelinked recent version built for Knoppix. It can be used with nearly any kernel version since 2.6.20 with a fuse kernel module. Nothing to install, just download, uncompress and mount as root with

Code:
linked-ntfs-3g /dev/sda1 /mnt/usb1_1


Regards

Jean-Pierre


Wed Nov 09, 2011 10:04
Profile

Joined: Wed Nov 09, 2011 08:42
Posts: 4
Post Re: ntfs-3g-mount: mount failed: Invalid argument
I compiled the latest ntfs-3g with a debug

Code:
--enable-shared=no --disable-mount-helper \
--with-fuse=internal --enable-debug --prefix=/usr --sysconfdir=/tmp \
--disable-mtab --disable-ldconfig --disable-library


Now, I have:

Code:
ntfs-3g 2011.4.12 integrated FUSE 27


when mounting, I have:

Code:
...
ntfs_mapping_pairs_decompress(): Entering
  ntfs_mapping_pairs_decompress_i(): Entering for attr 0xa0.
  Mapping pairs array successfully decompressed:
  NTFS-fs DEBUG: Dumping runlist (values in hex):
  VCN              LCN               Run length
  0                44                1               
  1                LCN_ENOENT        0                (runlist end)
ntfs_attr_pread_i(): Reading 4096 bytes from vcn 0, lcn 44, ofs 0.
ntfs_pread(): pos 180224, count 4096
ntfs_mst_post_read_fixup(): Entering
Entry not found.
Couldn't find name '.NTFS-3G' in pathname '.NTFS-3G/UserMapping'.
ntfs-3g-mount: mount failed: Invalid argument
ntfs_inode_real_close(): Entering for inode 3
ntfs_inode_real_close(): Entering for inode 6
ntfs_inode_real_close(): Entering for inode 0
ntfs_inode_real_close(): Entering for inode 1
ntfs_inode_real_close(): Entering for inode 5


Wed Nov 09, 2011 10:31
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: ntfs-3g-mount: mount failed: Invalid argument
Hi,

Code:
Couldn't find name '.NTFS-3G' in pathname '.NTFS-3G/UserMapping'.
ntfs-3g-mount: mount failed: Invalid argument

There is no relation between these two messages. The first one is a normal warning if you do not have a .NTFS-3G directory.

Has anything been written to the system log ?

You have used the option --disable-mtab which prevents ntfs-3g from checking whether the partition was already mounted. Are you sure it is not mounted ? Also make sure /mnt/usb1_1 is an existing directory.

Otherwise your partition could be corrupt. First do a couple of "chkdsk /f" to make sure it is sane, or at least do an "ntfsfix [-n] /dev/sda1"

Regards

Jean-Pierre


Wed Nov 09, 2011 11:33
Profile

Joined: Wed Nov 09, 2011 08:42
Posts: 4
Post Re: ntfs-3g-mount: mount failed: Invalid argument
system log have not references have been posted yet about ntfs-3g

I have kernel 2.6.21

usb storage formatting in NTFS by Windows 7


Wed Nov 09, 2011 14:59
Profile
NTFS-3G Lead Developer

Joined: Tue Sep 04, 2007 17:22
Posts: 1286
Post Re: ntfs-3g-mount: mount failed: Invalid argument
Hi again,

Quote:
I have kernel 2.6.21

Should be ok. At least at this stage
Quote:
usb storage formatting in NTFS by Windows 7

Please try to answer all my questions, or say why you cannot.
Additionally, please post the output of
Code:
ntfsinfo -fm /dev/sda1

Regards

Jean-Pierre


Wed Nov 09, 2011 16:55
Profile

Joined: Wed Nov 09, 2011 08:42
Posts: 4
Post Re: ntfs-3g-mount: mount failed: Invalid argument
this problem solved.

incorrect settings were major and minor in dev/fuse


Thu Nov 10, 2011 12:53
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.