FAQ SearchLogin
Tuxera Home
View unanswered posts | View active topics It is currently Sun Jan 17, 2021 21:22



Post new topic Reply to topic  [ 4 posts ] 
Extremly slow 
Author Message

Joined: Wed Apr 29, 2009 20:39
Posts: 3
Post Extremly slow
Hi all,
I am using NTFS-3g with my external HDD and internal too. Copying is extremly slow. Copying to external is about 400KB/s to 2MB/s, and internal about 2-3MB/s. External is eSata (plugged with SATA->eSATA cable ) and Internal is SATA. I am using Gentoo with Vanilla kernel 2.6.29.1 with TuxOnIce patch. I mount it: /dev/sdb1 /mnt/data ntfs-3g noauto,user,defaults,utf8 0 0 (/etc/fstab). I use disks on my Windows on second partition and I didn`t have any problems, copying is fine.
Here are some interesting facts:


Code:
#hdparm -i /dev/sdb
/dev/sdb:

Model=WD My Book                              , FwRev=01.01A01, SerialNo=     WD-WCAU46172029
Config={ Fixed }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=1, MultSect=?1?
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=1953525168
IORDY=yes, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes:  pio0 pio3 pio4
DMA modes:  mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
AdvancedPM=no WriteCache=enabled
Drive conforms to: ATA/ATAPI-6 T13 1410D revision 1:  ATA/ATAPI-4,5,6

* signifies the current active mode

# hdparm -tT /dev/sdb

/dev/sdb:
Timing cached reads:   1094 MB in  2.00 seconds = 546.47 MB/sec
Timing buffered disk reads:  264 MB in  3.02 seconds =  87.55 MB/sec

# hdparm /dev/sdb

/dev/sdb:
IO_support    =  0 (default)
readonly      =  0 (off)
readahead     = 256 (on)
geometry      = 121601/255/63, sectors = 1953525168, start = 0

# dmesg


[    2.646225] ata2.00: ATA-6: WD My Book, 01.01A01, max UDMA/133
[    2.840842] scsi 1:0:0:0: Direct-Access     ATA      WD My Book       01.0 PQ: 0 ANSI: 5
[    2.842682] sd 1:0:0:0: [sdb] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB)
[    2.844276] sd 1:0:0:0: [sdb] Write Protect is off
[    2.845818] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[    2.845857] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.847516] sd 1:0:0:0: [sdb] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB)
[    2.849110] sd 1:0:0:0: [sdb] Write Protect is off
[    2.850696] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[    2.850736] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.852373]  sdb: sdb1
[    2.894999] sd 1:0:0:0: [sdb] Attached SCSI disk

Anyone to help me? Please, I don`t know what to do :( Thanks a lot.


Wed Apr 29, 2009 21:44
Profile

Joined: Wed Apr 29, 2009 20:39
Posts: 3
Post Re: Extremly slow
Added: NTFS-3g version is 2009.3.8


Wed Apr 29, 2009 21:54
Profile
Tuxera CTO

Joined: Tue Nov 21, 2006 23:15
Posts: 1648
Post Re: Extremly slow
Did you check http://ntfs-3g.org/support.html#slow ?


Mon May 04, 2009 18:15
Profile

Joined: Wed Apr 29, 2009 20:39
Posts: 3
Post Re: Extremly slow
szaka wrote:

Yes, I had seen them before. But all of these are not possible reasons, why it is so slow. Maybe DMA. But I dont know how to turn it on. I used another distribution, where the copying was OK and i didnt change settings in BIOS. So I dont know why it is so slow :(


Wed May 06, 2009 17:03
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original forum style by Vjacheslav Trushkin.